Major 2026 Release - See It In Real Life
Resolved
Aug 17, 2026 at 1:00pm UTC
Maintenance ended
Affected services
Created
Aug 15, 2026 at 12:00am UTC
See it In Real Life
Reflekt Me 2026 · 14 August 2026 · Public announcement
We rebuilt the pieces merchants use every day: how the brand looks on the storefront, how you understand engagement, how you get media into the widget, how plans are billed, and how you reach us for help.
A clearer button on the product page
The app is now See it In Real Life. Shoppers get a new call-to-action on the product page. In the Shopify theme editor, the button stays visible while you design the layout. If a subscription is no longer active, shoppers see a grey button instead of a broken experience.
Dashboard
The client dashboard is the live engagement view inside the portal. Open it from the main nav, pick a date range, and see how people use See it In Real Life on your products.
Gallery, built for real catalogs
Gallery is now library-first. Upload many assets at once, keep drafts separate from what is live on the widget, and promote when you are ready. AI can suggest descriptions and tags in media preview so large drops take less manual labeling. You can also rename products and variants from the portal.
Widget settings
Preview the 2026 button in Widget Settings, tune live preview, hide empty variants, and adjust variant behavior before it hits the storefront.
Plans and billing
Shopify merchants choose and manage plans from Shopify billing. Direct accounts (no linked shop) subscribe by card. Four plans: Standard, Growth, Scale, and Unlimited. The portal shows a clear status when a trial is ending, and Billing stays in the account menu so you can change plan without hunting for a link.
Support
Support is now a page in the portal, not a link out to email. Open Support in the main nav to file a ticket and follow it until it is closed.
You can open a Feature Request, Question, Bug, or Expert Hours request. Add a short summary, optional details, and how you prefer to be reached. Open tickets stay in a list with status and last update. Open any ticket to read the thread and add a note when we are waiting on you.
Support stays available even when billing needs attention, so you can still reach us while a plan is being sorted.
If you are already on a trial, nothing changes until the trial ends: the storefront button stays clickable, and the portal will warn you before it does.
Affected services